summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary V. Vaughan <gary@gnu.org>2003-12-01 15:52:52 +0000
committerEric Blake <ebb9@byu.net>2007-10-05 22:00:49 -0600
commite868634aa11a1a29c7bf23d0d771213ec04aabe8 (patch)
tree798e8baafd6635efeb6b922e197c8e1880870f42 /configure.ac
parent848bdfc8b4a79891cf8be64a97e244b7467d1b89 (diff)
downloadm4-e868634aa11a1a29c7bf23d0d771213ec04aabe8.tar.gz
* config/mkstamp: Updated from CVS libtool.
* configure.ac: Generate a gnu coding standards compliant version number, and use it for the banner. * Makefile.am (stamp-vcl): New rules to force m4 to be regenerated mhen the TIMESTAMP changes in ChangeLog, but the file modification time doesn't (e.g. in cvs commit). Otherwise dist tarballs will contain the previous version number. * src/main.c: Make --version output conform to the GNU standard.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2a65d38e..f4a56147 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,7 +38,8 @@ TIMESTAMP=
case AC_PACKAGE_VERSION in
*[[acegikmoqsuwy]])
TIMESTAMP=`$CONFIG_SHELL config/mkstamp < $srcdir/ChangeLog`
- AS_BOX([Configuring AC_PACKAGE_TARNAME AC_PACKAGE_VERSION$TIMESTAMP])
+ test -z "$TIMESTAMP" || TIMESTAMP=" (Build:$TIMESTAMP)"
+ AS_BOX([Configuring AC_PACKAGE_TARNAME][$TIMESTAMP AC_PACKAGE_VERSION])
echo
;;
esac