summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 68d1a667..83a58432 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,18 @@
-SUBDIRS=intl po doc lib src checks examples
+AUTOMAKE_OPTIONS = 1.3b gnits
-EXTRA_DIST = gettext.m4 c-boxes.el # Franc,ois, is this still needed? (EB)
+SUBDIRS = acm4 intl po lib src doc examples tests
+# Tag before making distribution. Also, don't make a distribution if
+# checks fail. Also, make sure the NEWS file is up-to-date.
+cvs-dist: # distcheck # maintainer-check
+ cvs -q tag `echo "Release-$(VERSION)" | sed 's/\./-/g'`
+ $(MAKE) dist
+
+cvs-diff:
+ thisver=`echo "Release-$(VERSION)" | sed 's/\./-/g'`; \
+ if test -z "$$OLDVERSION"; then \
+ prevno=`echo "$(VERSION)" - 0.01 | bc | sed 's/^\./0./'`; \
+ else prevno="$$OLDVERSION"; fi; \
+ prevver=Release-`echo $$prevno | sed 's/\./-/g'`; \
+ cvs -f rdiff -c -r $$prevver -r $$thisver $(PACKAGE) \
+ > $(PACKAGE)-$$prevno-$(VERSION).diff