summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3c93cdf3..17cce617 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,18 +115,15 @@ if test "$gl_gcc_warnings" = yes; then
AC_SUBST([WERROR_CFLAGS])
nw=
- nw="$nw -Waggregate-return" # C90 is anachronistic
+ nw="$nw -Waggregate-return" # K&R is anachronistic
+ nw="$nw -Wtraditional-conversion" # K&R is anachronistic
+ nw="$nw -Wundef" # K&R is anachronistic
nw="$nw -Wlong-long" # C90 is anachronistic
- nw="$nw -Wundef" # Warns on '#if GNULIB_FOO' etc in gnulib
- nw="$nw -Wtraditional" # Warns on #elif which we use often
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
nw="$nw -Wpadded" # Our structs are not packed
- nw="$nw -Wredundant-decls" # Gnulib has multiple decls
nw="$nw -Wformat-nonliteral" # Needed in builtin.c
- nw="$nw -Wunreachable-code" # Needed in output.c
nw="$nw -Wconversion" # Too many warnings for now
nw="$nw -Wsign-conversion" # Too many warnings for now
- nw="$nw -Wtraditional-conversion" # Too many warnings for now
nw="$nw -Wcast-qual" # Too many warnings for now
nw="$nw -Wswitch-enum" # Too many warnings for now
# This, $nw, is the list of warnings we disable.