summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 62e5459b..3c93cdf3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
# Configure template for GNU m4. -*-Autoconf-*-
-# Copyright (C) 1991-1994, 2000-2002, 2004-2010, 2013 Free Software
+# Copyright (C) 1991-1994, 2000-2002, 2004-2013 Free Software
# Foundation, Inc.
#
# This file is part of GNU M4.
@@ -142,8 +142,13 @@ if test "$gl_gcc_warnings" = yes; then
AC_SUBST([WARN_CFLAGS])
- AC_DEFINE([_FORTIFY_SOURCE], [2],
- [enable compile-time and run-time bounds-checking, and some warnings])
+ AH_VERBATIM([FORTIFY_SOURCE],
+ [/* Enable compile-time and run-time bounds-checking, and some warnings,
+ without upsetting newer glibc. */
+ #if defined __OPTIMIZE__ && __OPTIMIZE__
+ # define _FORTIFY_SOURCE 2
+ #endif
+ ])
fi
# Use gcc's -pipe option if available: for faster compilation.