summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2023-01-08 09:38:59 -0500
committerPaul Smith <psmith@gnu.org>2023-01-08 10:45:24 -0500
commit0de7a0d3bf29a240c5e0fef79b5b3eae8a6a01f5 (patch)
tree7f454ba1998ae8ac0c63672d01697715d1f9038f /Makefile.am
parent1656cd051c7f28de359b1f188b20a5a688004267 (diff)
downloadmake-git-0de7a0d3bf29a240c5e0fef79b5b3eae8a6a01f5.tar.gz
Create src/mkcustom.h which is included by config.h
Put declarations for missing functions which we create in src/misc.c into a file which is included by config.h via AH_BOTTOM(). This ensures those prototypes are available, even in files added to lib/... from gnulib. * src/mkcustom.h: Add a new file with function declarations. * configure.ac: Include src/mkcustom.h in config.h with AH_BOTTOM() * Makefile.am: Add the header to the SRCS list. * src/makeint.h: Remove content that we added to src/mkcustom.h. * src/config.ami: Add #include "mkcustom.h" to specialized config.h. * src/config.h-vms: Ditto. * src/config.h.W32: Ditto. * src/configh.dos: Ditto.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 082ba42c..49190d64 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,8 +34,8 @@ make_SRCS = src/ar.c src/arscan.c src/commands.c src/commands.h \
src/getopt.h src/getopt1.c src/gettext.h src/guile.c \
src/hash.c src/hash.h src/implicit.c src/job.c src/job.h \
src/load.c src/loadapi.c src/main.c src/makeint.h src/misc.c \
- src/os.h src/output.c src/output.h src/read.c src/remake.c \
- src/rule.c src/rule.h src/shuffle.h src/shuffle.c \
+ src/mkcustom.h src/os.h src/output.c src/output.h src/read.c \
+ src/remake.c src/rule.c src/rule.h src/shuffle.h src/shuffle.c \
src/signame.c src/strcache.c src/variable.c src/variable.h \
src/version.c src/vpath.c