summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2022-07-04 17:20:30 -0400
committerPaul Smith <psmith@gnu.org>2022-07-09 10:46:47 -0400
commit3f3eecc115eae16c44a09988e3c49968f5aeb9fd (patch)
tree7a923a5d6472eaecf68b073cc6c47b1ac939ac3e /Makefile.am
parentb09e9af0b823498b151c64d25df078605c72ac4e (diff)
downloadmake-git-3f3eecc115eae16c44a09988e3c49968f5aeb9fd.tar.gz
* maintMakefile: Allow checkcfg rules to succeed.
We can no longer pass our mondo-warnings options to the builds, as these will impact all the code including gnulib code, and this won't work. Also allow the caller to disable either the build.sh or makefile invocation, for testing. * Makefile.am: Allow the caller to reset the path to the make binary to be tested. Remove c90 test: gnulib doesn't support it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e7d0e3c..70b2359c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -162,6 +162,8 @@ MAKETESTFLAGS =
.PHONY: check-regression
+GMK_OUTDIR=..
+
check-regression: tests/config-flags.pm
@if test -f '$(top_srcdir)/tests/run_make_tests'; then \
ulimit -n 128; \
@@ -174,8 +176,8 @@ check-regression: tests/config-flags.pm
rm -f tests/$$f; ln -s ../srctests/$$f tests; \
done; fi ;; \
esac; \
- echo "cd tests && $(PERL) $(PERLFLAGS) ./run_make_tests.pl -srcdir $(abs_top_srcdir) -make ../make$(EXEEXT) $(MAKETESTFLAGS)"; \
- cd tests && $(PERL) $(PERLFLAGS) ./run_make_tests.pl -srcdir '$(abs_top_srcdir)' -make '../make$(EXEEXT)' $(MAKETESTFLAGS); \
+ echo "cd tests && $(PERL) $(PERLFLAGS) ./run_make_tests.pl -srcdir $(abs_top_srcdir) -make $(GMK_OUTDIR)/make$(EXEEXT) $(MAKETESTFLAGS)"; \
+ cd tests && $(PERL) $(PERLFLAGS) ./run_make_tests.pl -srcdir '$(abs_top_srcdir)' -make '$(GMK_OUTDIR)/make$(EXEEXT)' $(MAKETESTFLAGS); \
else \
echo "Can't find a working Perl ($(PERL)); the test suite requires Perl."; \
fi; \