summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2016-03-08 23:07:14 -0500
committerPaul Smith <psmith@gnu.org>2016-03-08 23:40:46 -0500
commit85c788572d054bc2c41b84007875edbd37ad3ed5 (patch)
tree0e6f3a19d6f438528803a394f1df1000065d27c4 /Makefile.am
parent8164c8ab3da4026f16b7a8d343b136ebfaeaed8e (diff)
downloadmake-git-85c788572d054bc2c41b84007875edbd37ad3ed5.tar.gz
[SV 46261] Use pselect() for jobserver where supported.
* Makefile.am, configure.ac: Check for pselect() and sys/select.h. * main.c (main): Block SIGCHLD if we have pselect() support. * posixos.c (jobserver_acquire): If we support pselect() then use it to query the jobserver pipe, while also listening for SIGCHLD. Also pselect() supports a timeout so avoid alarm() calls.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c102a3c..96c4ae20 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,8 +16,8 @@
# You should have received a copy of the GNU General Public License along with
# this program. If not, see <http://www.gnu.org/licenses/>.
-AUTOMAKE_OPTIONS = 1.8 dist-bzip2 check-news
-ACLOCAL_AMFLAGS = -I config
+AUTOMAKE_OPTIONS = dist-bzip2 silent-rules std-options
+ACLOCAL_AMFLAGS = -I config
MAKE_HOST = @MAKE_HOST@