summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2016-04-02 17:18:40 -0400
committerPaul Smith <psmith@gnu.org>2016-04-04 01:36:08 -0400
commit86b20728fedfc7275f2aa2a47ca3c881b958562d (patch)
treef5e4ec323895ef6f30d9cec1fc6374fcdcb992c5 /Makefile.am
parentb8a8af655035ce06ca2b3e94ca763e6a89fa85a8 (diff)
downloadmake-git-86b20728fedfc7275f2aa2a47ca3c881b958562d.tar.gz
* Makefile.am, w32/Makefile.am: Fix *os.c for Windows builds.
Original change provided by Luke Allardyce <lukeallardyce@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 96c4ae20..edd6077d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,9 @@ if WINDOWSENV
MAYBE_W32 = w32
W32INC = -I $(top_srcdir)/w32/include
W32LIB = -Lw32 -lw32
+ ossrc =
+else
+ ossrc = posixos.c
endif
SUBDIRS = glob config po doc $(MAYBE_W32)
@@ -41,7 +44,7 @@ endif
make_SOURCES = ar.c arscan.c commands.c default.c dir.c expand.c file.c \
function.c getopt.c getopt1.c guile.c implicit.c job.c load.c \
- loadapi.c main.c misc.c output.c posixos.c read.c remake.c \
+ loadapi.c main.c misc.c $(ossrc) output.c read.c remake.c \
rule.c signame.c strcache.c variable.c version.c vpath.c \
hash.c $(remote)