summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2015-07-12 18:05:50 -0400
committerPaul Smith <psmith@gnu.org>2015-07-12 18:19:01 -0400
commitc18b23f7b249fb0ef17593b1641831fc05a56027 (patch)
tree0ca4298dee4e635719a04af847b10cd79e9772f9 /Makefile.am
parentfe5585528fe3b48084328bb0f713a071a6ee406a (diff)
downloadmake-git-c18b23f7b249fb0ef17593b1641831fc05a56027.tar.gz
* tests/scripts/misc/fopen-fail: [SV 42390] Increase test timeout.
* Makefile.am (check-regression): Force ulimit -n for fopen-fail test.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index d2451b88..958f37b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -126,8 +126,8 @@ guile.$(OBJEXT): gmk-default.h
gmk-default.h: $(srcdir)/gmk-default.scm
(echo 'static const char *const GUILE_module_defn = " '\\ \
&& sed -e 's/;.*//' -e '/^[ \t]*$$/d' -e 's/"/\\"/g' -e 's/$$/ \\/' \
- $(srcdir)/gmk-default.scm \
- && echo '";') > $@
+ $(srcdir)/gmk-default.scm \
+ && echo '";') > $@
# --------------- Local DIST Section
@@ -175,6 +175,7 @@ MAKETESTFLAGS =
check-regression: tests/config-flags.pm
@if test -f '$(srcdir)/tests/run_make_tests'; then \
+ ulimit -n 128; \
if $(PERL) -v >/dev/null 2>&1; then \
case `cd '$(srcdir)'; pwd` in `pwd`) : ;; \
*) test -d tests || mkdir tests; \
@@ -189,9 +190,9 @@ check-regression: tests/config-flags.pm
else \
echo "Can't find a working Perl ($(PERL)); the test suite requires Perl."; \
fi; \
- else \
+ else \
echo "Can't find the GNU Make test suite ($(srcdir)/tests)."; \
- fi
+ fi
# --------------- Maintainer's Section