summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2017-11-19 13:49:26 -0500
committerPaul Smith <psmith@gnu.org>2017-11-19 14:07:22 -0500
commitfb779d2f1e26a280f381886f3cdf444102676249 (patch)
tree4e3dca8cf801845720296a02e2f9266e4c30164b /Makefile.am
parent1af314465e5dfe3e8baa839a32a72e83c04f26ef (diff)
downloadmake-git-fb779d2f1e26a280f381886f3cdf444102676249.tar.gz
Rework directory structure to use GNU-recommended "src" directory.
Move the source code (other than glob) into the "src" subdirectory. Update all scripting and recommendations to support this change. * *.c, *.h, w32/*: Move to src/ * configure.ac, Makefile.am, maintMakefile: Locate new source files. * Basic.mk.template, mk/*: Update for new source file locations. * NEWS, README.DOS.template: Update for new locations. * build.template, build_w32.bat, builddos.bat: Ditto. * po/POTFILES.in: Ditto * tests/run_make_tests.pl, tests/scripts/features/load*: Ditto. * make.1: Move to doc. * mk/VMS.mk: Add support for building on VMS (hopefully). * makefile.vms, prepare_w32.bat: Remove. * SCOPTIONS: Update to define HAVE_CONFIG_H
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am82
1 files changed, 46 insertions, 36 deletions
diff --git a/Makefile.am b/Makefile.am
index 89e345e7..28e21a5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@
# You should have received a copy of the GNU General Public License along with
# this program. If not, see <http://www.gnu.org/licenses/>.
-AUTOMAKE_OPTIONS = dist-bzip2 silent-rules std-options subdir-objects
+AUTOMAKE_OPTIONS = dist-bzip2 silent-rules std-options subdir-objects nostdinc
ACLOCAL_AMFLAGS = -I config
MAKE_HOST = @MAKE_HOST@
@@ -24,29 +24,37 @@ MAKE_HOST = @MAKE_HOST@
SUBDIRS = glob config po doc
bin_PROGRAMS = make
-include_HEADERS = gnumake.h
+include_HEADERS = src/gnumake.h
-man_MANS = make.1
+man_MANS = doc/make.1
-make_SRCS = ar.c arscan.c commands.c commands.h debug.h default.c dep.h \
- dir.c expand.c file.c filedef.h function.c getopt.c getopt.h \
- getopt1.c gettext.h guile.c hash.c hash.h implicit.c job.c \
- job.h load.c loadapi.c main.c makeint.h misc.c os.h output.c \
- output.h read.c remake.c rule.c rule.h signame.c strcache.c \
- variable.c variable.h version.c vpath.c
+make_SRCS = src/ar.c src/arscan.c src/commands.c src/commands.h \
+ src/debug.h src/default.c src/dep.h src/dir.c src/expand.c \
+ src/file.c src/filedef.h src/function.c src/getopt.c \
+ src/getopt.h src/getopt1.c src/gettext.h src/guile.c \
+ src/hash.c src/hash.h src/implicit.c src/job.c src/job.h \
+ src/load.c src/loadapi.c src/main.c src/makeint.h src/misc.c \
+ src/os.h src/output.c src/output.h src/read.c src/remake.c \
+ src/rule.c src/rule.h src/signame.c src/strcache.c \
+ src/variable.c src/variable.h src/version.c src/vpath.c
glob_SRCS = glob/fnmatch.c glob/fnmatch.h glob/glob.c glob/glob.h
-w32_SRCS = w32/pathstuff.c w32/w32os.c w32/compat/dirent.c \
- w32/compat/posixfcn.c w32/include/dirent.h w32/include/dlfcn.h \
- w32/include/pathstuff.h w32/include/sub_proc.h \
- w32/include/w32err.h w32/subproc/misc.c w32/subproc/proc.h \
- w32/subproc/sub_proc.c w32/subproc/w32err.c
+loadavg_SRCS = src/getloadavg.c
-vms_SRCS = vms_exit.c vms_export_symbol.c vms_progname.c vmsdir.h \
- vmsfunctions.c vmsify.c vmsjobs.c
+alloca_SRCS = src/alloca.c
-amiga_SRCS = amiga.c amiga.h
+w32_SRCS = src/w32/pathstuff.c src/w32/w32os.c src/w32/compat/dirent.c \
+ src/w32/compat/posixfcn.c src/w32/include/dirent.h \
+ src/w32/include/dlfcn.h src/w32/include/pathstuff.h \
+ src/w32/include/sub_proc.h src/w32/include/w32err.h \
+ src/w32/subproc/misc.c src/w32/subproc/proc.h \
+ src/w32/subproc/sub_proc.c src/w32/subproc/w32err.c
+
+vms_SRCS = src/vms_exit.c src/vms_export_symbol.c src/vms_progname.c \
+ src/vmsdir.h src/vmsfunctions.c src/vmsify.c
+
+amiga_SRCS = src/amiga.c src/amiga.h
make_SOURCES = $(make_SRCS)
EXTRA_make_SOURCES = $(amiga_SRCS) $(vms_SRCS)
@@ -56,42 +64,44 @@ make_LDADD = $(GUILE_LIBS) $(LIBOBJS) $(ALLOCA) $(GLOBLIB) \
localedir = $(datadir)/locale
-AM_CPPFLAGS = -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\" \
- -DLOCALEDIR=\"$(localedir)\" $(GLOBINC)
+AM_CPPFLAGS = -Isrc -I$(srcdir)/src $(GLOBINC) -DLIBDIR=\"$(libdir)\" \
+ -DINCLUDEDIR=\"$(includedir)\" -DLOCALEDIR=\"$(localedir)\"
AM_CFLAGS = $(GUILE_CFLAGS)
if WINDOWSENV
make_SOURCES += $(w32_SRCS)
- AM_CPPFLAGS += -I $(top_srcdir)/w32/include
+ AM_CPPFLAGS += -I $(top_srcdir)/src/w32/include
else
- make_SOURCES += posixos.c
+ make_SOURCES += src/posixos.c
endif
if USE_CUSTOMS
- make_SOURCES += remote-cstms.c
+ make_SOURCES += src/remote-cstms.c
else
- make_SOURCES += remote-stub.c
+ make_SOURCES += src/remote-stub.c
endif
# Extra stuff to include in the distribution.
-mk_FILES = Basic.mk mk/Amiga.mk mk/Windows32.mk mk/msdosdjgpp.mk
+mk_FILES = Basic.mk mk/msdosdjgpp.mk mk/Amiga.mk mk/VMS.mk mk/Windows32.mk
+# We don't need this, since the standard automake output will do.
+#mk/Posix.mk.in
-# test/scripts are added via dist-hook below.
test_FILES = tests/run_make_tests tests/run_make_tests.bat \
tests/run_make_tests.pl tests/test_driver.pl \
tests/config-flags.pm.in tests/config_flags_pm.com \
tests/mkshadow tests/jhelp.pl tests/guile.supp tests/README
+# test/scripts are added via dist-hook below.
EXTRA_DIST = ChangeLog README build.sh.in $(man_MANS) \
README.customs README.OS2 \
- README.Amiga SCOPTIONS config.ami \
- README.DOS builddos.bat configh.dos \
- README.W32 config.h.W32 build_w32.bat \
- README.VMS makefile.vms makefile.com config.h-vms \
+ README.Amiga SCOPTIONS src/config.ami \
+ README.DOS builddos.bat src/configh.dos \
+ README.W32 build_w32.bat src/config.h.W32 \
+ README.VMS makefile.com src/config.h-vms src/vmsjobs.c \
vms_export_symbol_test.com \
- gmk-default.scm gmk-default.h \
+ src/gmk-default.scm src/gmk-default.h \
$(mk_FILES) $(test_FILES)
@@ -130,12 +140,12 @@ install-exec-local:
# --------------- Generate the Guile default module content
-guile.$(OBJEXT): gmk-default.h
-gmk-default.h: $(srcdir)/gmk-default.scm
+src/guile.$(OBJEXT): src/gmk-default.h
+src/gmk-default.h: $(srcdir)/src/gmk-default.scm
(echo 'static const char *const GUILE_module_defn = " '\\ \
&& sed -e 's/;.*//' -e '/^[ \t]*$$/d' -e 's/"/\\"/g' -e 's/$$/ \\/' \
- $(srcdir)/gmk-default.scm \
- && echo '";') > $@
+ $(srcdir)/src/gmk-default.scm \
+ && echo '";') > src/gmk-default.h
# --------------- Local DIST Section
@@ -169,8 +179,8 @@ check-loadavg: loadavg$(EXEEXT)
# The loadavg function is invoked during "make check" to test getloadavg.
check_PROGRAMS = loadavg
-nodist_loadavg_SOURCES = getloadavg.c
-loadavg_CPPFLAGS = -DTEST
+nodist_loadavg_SOURCES = $(loadavg_SRCS)
+loadavg_CPPFLAGS = -Isrc -I$(srcdir)/src -DTEST
loadavg_LDADD = @GETLOADAVG_LIBS@
# > check-regression