summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2022-10-09 13:41:21 -0400
committerPaul Smith <psmith@gnu.org>2022-10-15 18:39:32 -0400
commit01b1d4f40195ddb715bc8a5e2236a7fe2e92890f (patch)
tree26a72161e7130d3e77fbebf27473d6ae93903a4d /configure.ac
parentbf2d71498c12ee09b6c9fe63a337c306442fd7f6 (diff)
downloadmake-git-01b1d4f40195ddb715bc8a5e2236a7fe2e92890f.tar.gz
Set the proper type for variables set in signal handlers
* bootstrap.conf: Get gnulib's sig_atomic_t type checking M4 macro. * configure.ac: Invoke it. * src/makeint.h (handling_fatal_signal): Set the type correctly. * src/commands.c (handling_fatal_signal): Ditto.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f5d9810..e953bf1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,6 +78,9 @@ AC_TYPE_SSIZE_T
AC_TYPE_INTMAX_T
AC_TYPE_UINTMAX_T
+# Check for sig_atomic_t
+gt_TYPE_SIG_ATOMIC_T
+
# Find out whether our struct stat returns nanosecond resolution timestamps.
AC_STRUCT_ST_MTIM_NSEC