summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2023-01-08 09:38:59 -0500
committerPaul Smith <psmith@gnu.org>2023-01-08 10:45:24 -0500
commit0de7a0d3bf29a240c5e0fef79b5b3eae8a6a01f5 (patch)
tree7f454ba1998ae8ac0c63672d01697715d1f9038f /configure.ac
parent1656cd051c7f28de359b1f188b20a5a688004267 (diff)
downloadmake-git-0de7a0d3bf29a240c5e0fef79b5b3eae8a6a01f5.tar.gz
Create src/mkcustom.h which is included by config.h
Put declarations for missing functions which we create in src/misc.c into a file which is included by config.h via AH_BOTTOM(). This ensures those prototypes are available, even in files added to lib/... from gnulib. * src/mkcustom.h: Add a new file with function declarations. * configure.ac: Include src/mkcustom.h in config.h with AH_BOTTOM() * Makefile.am: Add the header to the SRCS list. * src/makeint.h: Remove content that we added to src/mkcustom.h. * src/config.ami: Add #include "mkcustom.h" to specialized config.h. * src/config.h-vms: Ditto. * src/config.h.W32: Ditto. * src/configh.dos: Ditto.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8466d36f..f5781853 100644
--- a/configure.ac
+++ b/configure.ac
@@ -471,6 +471,10 @@ AC_SUBST_FILE([MAINT_MAKEFILE])
# Allow building with dmalloc
AM_WITH_DMALLOC
+# Add custom header to config.h
+AH_BOTTOM([/* Include customized declarations. */
+#include "../src/mkcustom.h"])
+
# Forcibly disable SET_MAKE. If it's set it breaks things like the test
# scripts, etc.
SET_MAKE=