summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2022-10-16 15:13:41 -0400
committerPaul Smith <psmith@gnu.org>2022-10-18 14:20:44 -0400
commit2d943d3d2e5b69d6b635314a46d20e55cfbd255a (patch)
treeeb272d7661251ee0aecdf5357519c734110cbea1 /configure.ac
parentb16913a67e1d0f651293d24f10ccca54a8cc0d08 (diff)
downloadmake-git-2d943d3d2e5b69d6b635314a46d20e55cfbd255a.tar.gz
Remove template files to simplify distribution creation
The README templates were not useful since the replacement step didn't have anything to replace: rename them. Rather than creating template files for the config variants, create mkconfig.h.in containg PACKAGE_* variables to be replaced, and have config variant header files include it. Note on POSIX we don't use this, and continue to generate a single config.h.in file. Use config.status to convert the README.in and mkconfig.h.in files during distribution creation. Modify all users of VERSION to use PACKAGE_VERSION instead. * configure.ac: Use GNU Make not GNU make as the package name. * README.in: Use GNU Make not GNU make. * README.git: Remove references to README.W32.template. * .gitignore: Update for new behavior. * Basic.mk.template: Remove unused posix_SOURCES and VERSION, and references to unshipped mk/Posix.mk * Makefile.am: Add src/mkconfig.h as an extra dist file. * bootstrap.bat: Rewrite mkconfig.h.in to mkconfig.h * maintMakefile: Remove obsolete template files; add mkconfig.h.in. * prepare_vms.com: Rewrite mkconfig.h.in to mkconfig.h * mk/VMS.mk: Fix incorrect header file prerequisite. * src/mkconfig.h.in: New file containing PACKAGE variables. * src/config.ami: Include mkconfig.h. * src/config.h.W32: Ditto. * src/configh.dos: Ditto. * src/config.h-vms: Ditto. * src/version.c: Use PACKAGE_VERSION not VERSION.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e953bf1a..e9a66898 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@
# You should have received a copy of the GNU General Public License along with
# this program. If not, see <http://www.gnu.org/licenses/>.
-AC_INIT([GNU make],[4.3.91],[bug-make@gnu.org])
+AC_INIT([GNU Make],[4.3.91],[bug-make@gnu.org])
AC_PREREQ([2.69])
@@ -509,8 +509,8 @@ AM_CONDITIONAL([KNOWN_PREFIX],
-o "x$prefix" = x/usr/gnu -o "x$prefix" = x/usr])
# Specify what files are to be created.
-AC_CONFIG_FILES([Makefile build.cfg lib/Makefile po/Makefile.in doc/Makefile \
- tests/config-flags.pm])
+AC_CONFIG_FILES([build.cfg tests/config-flags.pm \
+ Makefile lib/Makefile doc/Makefile po/Makefile.in])
# We don't need this: the standard automake output suffices for POSIX systems.
#mk/Posix.mk