summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2019-09-07 16:59:46 -0400
committerPaul Smith <psmith@gnu.org>2019-09-07 20:12:44 -0400
commitc0cb9c8b3d0b163f845a867138379b0ef586a0c8 (patch)
treedffb12625d65c889527ff102337315edd6e3ebd2 /configure.ac
parent34ee9adaed8e5dc094456a901386aee24ee114f3 (diff)
downloadmake-git-c0cb9c8b3d0b163f845a867138379b0ef586a0c8.tar.gz
* configure.ac: Check whether struct dirent has a d_type field
* src/dir.c (dir_contents_file_exists_p): Use the autoconf macro HAVE_STRUCT_DIRENT_D_TYPE rather than relying on the GNU libc- specific _DIRENT_HAVE_D_TYPE. * lib/glob.c: Set HAVE_D_TYPE if HAVE_STRUCT_DIRENT_D_TYPE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da1e17dd..a1f25553 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,6 +164,9 @@ AC_CHECK_FUNCS([strcasecmp strncasecmp strcmpi strncmpi stricmp strnicmp])
AC_FUNC_STRCOLL
AC_FUNC_CLOSEDIR_VOID
+# dir.c and our glob.c use dirent.d_type if available
+AC_STRUCT_DIRENT_D_TYPE
+
# See if the user wants to add (or not) GNU Guile support
AC_ARG_WITH([guile], [AS_HELP_STRING([--with-guile],
[Support GNU Guile for embedded scripting])])