summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJouke Witteveen <j.witteveen@gmail.com>2019-10-26 12:24:29 +0200
committerPaul Smith <psmith@gnu.org>2019-12-17 15:06:28 -0500
commitc72205b28b93ee546027ad5297ba1771f31256a6 (patch)
tree52353cc828dbb04dbda99b51bf22599ffb945e02 /configure.ac
parent057e33d6b5bb41d8e0deed0c5ac4d5d72047e7f4 (diff)
downloadmake-git-c72205b28b93ee546027ad5297ba1771f31256a6.tar.gz
* src/implicit.c (pattern_search): Set lastslash correctly
If filename contained multiple slashes lastslash is wrongly set to 0. * configure.ac: Check for the GNU memrchr() extension function. * src/misc.c (memrchr): Supply memrchr() if not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e12a5b83..af58c1b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -138,7 +138,7 @@ AS_IF([test "$ac_cv_func_gettimeofday" = yes],
[Define to 1 if you have a standard gettimeofday function])
])
-AC_CHECK_FUNCS([strdup strndup umask mkstemp mktemp fdopen \
+AC_CHECK_FUNCS([strdup strndup memrchr umask mkstemp mktemp fdopen \
dup dup2 getcwd realpath sigsetmask sigaction \
getgroups seteuid setegid setlinebuf setreuid setregid \
getrlimit setrlimit setvbuf pipe strsignal \