summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2022-06-26 15:55:25 -0400
committerPaul Smith <psmith@gnu.org>2022-07-09 10:46:47 -0400
commitd63925d8637db8acd4f2e62f8cbc9f70a07501d8 (patch)
treeb0cb0142d8300ac4b10a96aaf30c74e45979310d /configure.ac
parent0793658c09a8f33581dae6dfbe2483ea279e72b1 (diff)
downloadmake-git-d63925d8637db8acd4f2e62f8cbc9f70a07501d8.tar.gz
bootstrap: Remove gnulib version of mempcpy()
This pulls in a metric ton of stuff that we otherwise don't need, just for a one-liner that we already have a replacement for in src/misc.c. * bootstrap.conf: Remove mempcpy * configure.ac: Add mempcpy to AC_CHECK_FUNCS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d43cfd78..da6d6a5f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,7 +133,7 @@ AS_IF([test "$ac_cv_func_gettimeofday" = yes],
[Define to 1 if you have a standard gettimeofday function])
])
-AC_CHECK_FUNCS([strdup strndup memrchr umask mkstemp mktemp fdopen \
+AC_CHECK_FUNCS([strdup strndup memrchr mempcpy umask mkstemp mktemp fdopen \
dup dup2 getcwd realpath sigsetmask sigaction \
getgroups seteuid setegid setlinebuf setreuid setregid \
getrlimit setrlimit setvbuf pipe strsignal \