summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2002-07-08 02:26:47 +0000
committerPaul Smith <psmith@gnu.org>2002-07-08 02:26:47 +0000
commita6d956962e42c3a784d9f603ad552c588a3ac5f8 (patch)
tree8e590714da1d480bef4ca2afbe81fa95c2624de6 /Makefile.am
parent15e2f5e1a9e18dc19a7a365980b70ff920c4c8a5 (diff)
downloadmake-a6d956962e42c3a784d9f603ad552c588a3ac5f8.tar.gz
Major updates in preparation for 3.80.
New version of the manual, put into the doc subdir. Enhancements: $(eval ...) and $(value ...) functions, various bug fixes, etc. See the ChangeLog. More to come.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c393a966..5d70f420 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,7 @@
AUTOMAKE_OPTIONS = 1.6 dist-bzip2
ACLOCAL_AMFLAGS = -I config
-SUBDIRS = glob config po
+SUBDIRS = glob config po doc
bin_PROGRAMS = make
@@ -23,10 +23,9 @@ EXTRA_make_SOURCES = remote-stub.c remote-cstms.c
noinst_HEADERS = commands.h dep.h filedef.h job.h make.h rule.h variable.h \
debug.h getopt.h gettext.h
-make_LDADD = @LIBOBJS@ @ALLOCA@ $(GLOBLIB) @GETLOADAVG_LIBS@
+make_LDADD = @LIBOBJS@ @ALLOCA@ $(GLOBLIB) @GETLOADAVG_LIBS@ @LIBINTL@
man_MANS = make.1
-info_TEXINFOS = make.texinfo
DEFS = -DLOCALEDIR=\"$(localedir)\" -DLIBDIR=\"$(libdir)\" -DINCLUDEDIR=\"$(includedir)\" @DEFS@
@@ -40,7 +39,7 @@ AM_CPPFLAGS = $(GLOBINC)
EXTRA_DIST = README build.sh.in $(man_MANS)\
README.customs\
- make-stds.texi SCOPTIONS SMakefile\
+ SCOPTIONS SMakefile\
README.Amiga Makefile.ami config.ami make.lnk amiga.c amiga.h\
README.DOS Makefile.DOS configure.bat dosbuild.bat configh.dos\
README.W32 NMakefile config.h.W32 build_w32.bat subproc.bat\
@@ -50,6 +49,13 @@ EXTRA_DIST = README build.sh.in $(man_MANS)\
MAKE_HOST = @MAKE_HOST@
+# Forward targets
+
+html pdf:
+ cd doc && $(MAKE) $(AM_MAKEFLAGS) $@
+
+.PHONY: html pdf
+
# --------------- Internationalization Section
localedir = $(datadir)/locale