summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2002-09-12 22:15:58 +0000
committerPaul Smith <psmith@gnu.org>2002-09-12 22:15:58 +0000
commitd939d574375c52682a9c9461259691af235b9073 (patch)
treec66f531406bd1e48a85a02fc70e8688d9b4221f3 /Makefile.am
parentd932c9780b08c7786f19056f84d39b0e3025bf2b (diff)
downloadmake-d939d574375c52682a9c9461259691af235b9073.tar.gz
Fixups for the release. One bug fix, some automake complaint fixes,
and a function return type fix for older systems.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2afb6b9d..e00cc6fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -121,10 +121,13 @@ check-loadavg: loadavg
# The loadavg function is invoked during "make check" to test getloadavg.
noinst_PROGRAMS = loadavg
-loadavg_SOURCES = getloadavg.c
+loadavg_SOURCES = loadavg.c
loadavg_CFLAGS = -DTEST
loadavg_LDADD = @GETLOADAVG_LIBS@
+loadavg.c: $(srcdir)/getloadavg.c
+ cp $(srcdir)/getloadavg.c loadavg.c
+
# > check-regression
#
# Look for the make test suite, and run it if found and we can find perl.