summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Smith <psmith@gnu.org>2013-05-06 00:22:27 -0400
committerPaul Smith <psmith@gnu.org>2013-05-06 00:22:27 -0400
commit31f3ffe8a1e9c24433441fd0f3353de02edfc7e1 (patch)
treefe07174cab4eba5d50ee5ad04684cfee6e454b08 /configure.ac
parent127757adcbc281e3cd1476947bebc9131ae05d27 (diff)
downloadmake-31f3ffe8a1e9c24433441fd0f3353de02edfc7e1.tar.gz
Remove use of vfork().
GCC was giving us warnings, most OS's now just run fork() when you call vfork(), and looking at the standard definition of vfork() we are a long way from using it safely anyway: you're not allowed to even call a function before you exec().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 45b201c2..7b70f045 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,7 +153,6 @@ AC_CHECK_FUNCS([strcasecmp strncasecmp strcmpi strncmpi stricmp strnicmp])
AC_FUNC_STRCOLL
AC_FUNC_ALLOCA
-AC_FUNC_FORK([])
AC_FUNC_CLOSEDIR_VOID
# See if the user wants to add (or not) GNU Guile support