summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Hourihane <alanh@fairlite.co.uk>2014-01-20 00:17:44 -0500
committerPaul Smith <psmith@gnu.org>2014-01-20 00:17:44 -0500
commit4ae2d9795428e2eb097cc04edbbff5cf109a6fa1 (patch)
tree47140490b4bd2b78bcadb1f5778656b8140de86b /configure.ac
parent707ed54e22c5870ffd05be241ba78c31f171c6e0 (diff)
downloadmake-4ae2d9795428e2eb097cc04edbbff5cf109a6fa1.tar.gz
* configure.ac: [SV 40790] Fix load autoconf variables.
Copyright-paperwork-exempt: yes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 8e11328d..0922e777 100644
--- a/configure.ac
+++ b/configure.ac
@@ -318,20 +318,20 @@ AC_ARG_ENABLE([load],
[make_cv_load="$enableval" user_load="$enableval"],
[make_cv_load="yes"])
-AS_CASE([/$ac_cv_func_dlopen/$ac_cv_func_dlsym/$ac_cv_func_dlerror/],
+AS_CASE([/$ac_cv_have_decl_dlopen/$ac_cv_have_decl_dlsym/$ac_cv_have_decl_dlerror/],
[*/no/*], [make_cv_load=no])
+# We might need -ldl
+AS_IF([test "$make_cv_load" = yes], [
+ AC_SEARCH_LIBS([dlopen], [dl], [], [make_cv_load=])
+ ])
+
AS_CASE([/$make_cv_load/$user_load/],
[*/no/*], [make_cv_load=no],
[AC_DEFINE(MAKE_LOAD, 1,
[Define to 1 to enable 'load' support in GNU make.])
])
-# We might need -ldl
-AS_IF([test "$make_cv_load" = yes], [
- AC_SEARCH_LIBS([dlopen], [dl], [], [make_cv_load=])
- ])
-
# If we want load support, we might need to link with export-dynamic.
# See if we can figure it out. Unfortunately this is very difficult.
# For example passing -rdynamic to the SunPRO linker gives a warning