summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Krivonos <name@localhost.localdomain>2021-10-17 12:36:12 +0300
committerSergei Krivonos <name@localhost.localdomain>2021-10-17 13:20:49 +0300
commit052dda61bb8d5fef271ecd091a5b5db25d57040b (patch)
tree4fde1a821b603d795e6451433e00c04d11dcaaa5 /CMakeLists.txt
parentcf8e78a40170118e2595e35c9c5f43aedeca91a0 (diff)
downloadmariadb-git-052dda61bb8d5fef271ecd091a5b5db25d57040b.tar.gz
Made optional Json_writer_object / Json_writer_array consistency check
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 591920450ea..2bafbda9964 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -185,6 +185,10 @@ IF(DISABLE_SHARED)
SET(WITHOUT_DYNAMIC_PLUGINS 1)
ENDIF()
OPTION(ENABLED_PROFILING "Enable profiling" ON)
+OPTION(ENABLED_JSON_WRITER_CONSISTENCY_CHECKS "Enable Json_writer_object / Json_writer_array checking to produce consistent JSON output" OFF)
+IF(ENABLED_JSON_WRITER_CONSISTENCY_CHECKS)
+ ADD_DEFINITIONS(-DENABLED_JSON_WRITER_CONSISTENCY_CHECKS)
+ENDIF()
OPTION(WITHOUT_SERVER "Build only the client library and clients" OFF)
IF(UNIX)
OPTION(WITH_VALGRIND "Valgrind instrumentation" OFF)