summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@mariadb.org>2016-10-10 11:28:26 +0300
committerOtto Kekäläinen <otto@mariadb.org>2016-10-27 18:42:17 +0300
commit19cffe69c240e58dc865c7df2f781078c04dbc23 (patch)
tree8a3141d7863167d25e7fb09bd933e4b5977f541d /CMakeLists.txt
parentf63799d068530a5b460848fadd4930d44fb89d7c (diff)
downloadmariadb-git-19cffe69c240e58dc865c7df2f781078c04dbc23.tar.gz
MDEV-6284: Revert commit af03ba84 partially for systemd
This version of Debian packaging does not yet install systemd scripts, so revert that part to the CMakeLists.txt based hack.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b19b796621f..54b3cbee939 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -435,6 +435,12 @@ CONFIGURE_FILE(
${CMAKE_SOURCE_DIR}/cmake/info_macros.cmake.in
${CMAKE_BINARY_DIR}/info_macros.cmake @ONLY)
+IF(DEB)
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/debian/mariadb-server-10.2.install.in
+ ${CMAKE_SOURCE_DIR}/debian/mariadb-server-10.2.install)
+ENDIF(DEB)
+
# Handle the "INFO_*" files.
INCLUDE(${CMAKE_BINARY_DIR}/info_macros.cmake)
# Source: This can be done during the cmake phase, all information is