summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSachin Setiya <sachinsetia1001@gmail.com>2018-04-19 13:04:58 +0530
committerSachin Setiya <sachinsetia1001@gmail.com>2018-04-19 13:08:35 +0530
commit547b00d910b8d5e1526c00aeac9425b182cbea5e (patch)
tree4482f03ba92cd14cdf3503d0cc4d65e0049cddb1 /CMakeLists.txt
parentdde0ba5aaaf653af3079939536a8dd0f90abbb41 (diff)
downloadmariadb-git-547b00d910b8d5e1526c00aeac9425b182cbea5e.tar.gz
MDEV-12924 No --innodb-numa-interleave in mysqld binaries
It changes the cmake WITH_NUMA option to have 3 values Auto:- If libnuma present compile with numa (Default value) OFF:- Compile without libnuma On:- Compile with numa , throw error if libnuma not present Patch Contributer:- Vesa Patch Reviewer:- serg
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94362c349f2..52f511ec0c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -129,6 +129,9 @@ IF(DEFINED ENV{CPPFLAGS})
ADD_DEFINITIONS($ENV{CPPFLAGS})
ENDIF()
+# NUMA
+SET(WITH_NUMA "AUTO" CACHE STRING "Build with non-uniform memory access, allowing --innodb-numa-interleave. Options are ON|OFF|AUTO. ON = enabled (requires NUMA library), OFF = disabled, AUTO = enabled if NUMA library found.")
+
SET(MYSQL_MAINTAINER_MODE "AUTO" CACHE STRING "MySQL maintainer-specific development environment. Options are: ON OFF AUTO.")
# Packaging