summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent.boortz@sun.com>2008-11-06 19:38:19 +0100
committerBuild Team <bteam@astra04>2008-11-06 19:38:19 +0100
commit2f08a0798d935ccd93e4bc2ee34dd60e0c9c3c0f (patch)
tree597b1c9155fa14c05cfc6653eba9966dc7eb73bd /Makefile.am
parente9be23fae6129b96cf20fa5a0938a7bad77a5df2 (diff)
downloadmariadb-git-2f08a0798d935ccd93e4bc2ee34dd60e0c9c3c0f.tar.gz
Back merges from 6.0.8
- Removed some copy/paste between debug and normal build in RPM spec - Removed "mysql_upgrade_shell" from RPM build - Removed use of "grep -q" in "configure.in", not portable - Improved test to disable ABI check not to accidently run for icc Other changes - Added make file test targets 'test-bt-fast' and 'test-bt-debug-fast' - Reenabled "jp" test suite run
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 18 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c0a5334a032..26670c42305 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -159,6 +159,8 @@ test-bt:
@PERL@ ./mysql-test-run.pl --force --comment=partitions --suite=parts
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=stress --suite=stress
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=jp --suite=jp
-if [ -d mysql-test/suite/nist ] ; then \
cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=nist --force --suite=nist ; \
@@ -175,15 +177,28 @@ test-bt:
echo "no program found for 'embedded' tests - skipped testing" ; \
fi
-# Re-enable the "jp" suite when bug#28563 is fixed
-# -cd mysql-test ; MTR_BUILD_THREAD=auto \
-# @PERL@ ./mysql-test-run.pl --force --comment=jp --suite=jp
+test-bt-fast:
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=ps --force --timer \
+ --skip-ndbcluster --ps-protocol
+ -if [ -e bin/ndbd -o -e storage/ndb/src/kernel/ndbd ] ; then \
+ cd mysql-test ; \
+ MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=ndb --force --timer \
+ --with-ndbcluster-only ; \
+ else \
+ echo "no program found for 'ndbcluster' tests - skipped testing" ; \
+ fi
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=stress --suite=stress
test-bt-debug:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=debug --force --timer \
--skip-ndbcluster --skip-rpl --report-features
+test-bt-debug-fast:
+
# Keep these for a while
test-pl: test
test-full-pl: test-full