summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@trift2.>2007-05-24 15:20:06 +0200
committerunknown <joerg@trift2.>2007-05-24 15:20:06 +0200
commit6279ade702ef1ab5c81608893b9525d5c929afba (patch)
tree142bbb3b31741444b5ea5aad2c6f88d2fbde171a /Makefile.am
parenta1fbcb24aafbc56b305857e7d4d859a5f1e96fd6 (diff)
downloadmariadb-git-6279ade702ef1ab5c81608893b9525d5c929afba.tar.gz
Makefile.am : Add "embedded" tests to the "test-bt" target.
Makefile.am: The "test-bt" target was lacking "embedded" tests - add them, dependent on the build of the test binary needed for them.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 69ea5809e89..b92ee7ae0bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -123,6 +123,11 @@ test-bt:
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --comment=NDB --force --timer \
--with-ndbcluster-only
+ -if [ -e bin/mysqltest_embedded -o -e libmysqld/examples/mysqltest_embedded ] ; then \
+ cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --comment=embedded --force --timer \
+ --embedded-server --skip-rpl --skip-ndbcluster ; \
+ fi
-cd mysql-test ; MTR_BUILD_THREAD=auto \
@PERL@ ./mysql-test-run.pl --force --comment=funcs1_ps --ps-protocol --suite=funcs_1
-cd mysql-test ; MTR_BUILD_THREAD=auto \