summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2006-12-02 23:16:47 +0100
committerunknown <kent@mysql.com/kent-amd64.(none)>2006-12-02 23:16:47 +0100
commitca3e99d85c28310068fe4b176ad3b05cf78c9b9d (patch)
tree9b1fa0a5db3a3cbc452349f2f40cf07832746ab3 /Makefile.am
parentbc6e2e9feb4cd8ed97287f36acee3e2520eb360c (diff)
downloadmariadb-git-ca3e99d85c28310068fe4b176ad3b05cf78c9b9d.tar.gz
mysql_install_db.sh:
If --srcdir and --windows is given, check if error message file is in source or build tree (bug#24557) Makefile.am: Cleaned up "ali_check" target, to satisfy "distcleancheck" (bug#24557) mysql_install_db.sh: Added --srcdir=DIR option, used from top Makefile.am in dist-hook target, to find "fill_help_tables.sql" in VPATH build (bug#24557) Makefile.am: Work around problem with "distcleancheck", "sql_yacc.cc" might be in both the source and build tree. Call "mysql_install_db" with new option --srcdir, to enable the script to find all that is needed, if source and build directory is not the same (bug#24557) scripts/mysql_install_db.sh: If --srcdir and --windows is given, check if error message file is in source or build tree (bug#24557) Makefile.am: Work around problem with "distcleancheck", "sql_yacc.cc" might be in both the source and build tree. Call "mysql_install_db" with new option --srcdir, to enable the script to find all that is needed, if source and build directory is not the same (bug#24557) include/Makefile.am: Cleaned up "ali_check" target, to satisfy "distcleancheck" (bug#24557)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 13 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 9752075fe78..6038825c928 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,6 +49,14 @@ BUILT_SOURCES = linked_client_sources linked_server_sources \
CLEANFILES = $(BUILT_SOURCES) bdb/build_unix/db.h
DISTCLEANFILES = ac_available_languages_fragment
+# Our current filtering of "sql_yacc.cc" in "sql/Makefile.am" creates
+# a problem, if a VPATH build and "sql_yacc.cc" was part of the source
+# distribution we end up with one "sql_yacc.cc" in the source tree,
+# and one in the build tree. This breaks "distcleancheck", until this
+# is sorted out we redefine the find that scans for files not removed
+
+distcleancheck_listfiles = find . -name sql_yacc.cc -o -type f -print
+
linked_include_sources:
cd include; $(MAKE) link_sources
echo timestamp > linked_include_sources
@@ -93,17 +101,11 @@ bin-dist: all
dist-hook:
rm -rf `find $(distdir) -type d -name SCCS -print`
rm -f `find $(distdir) -type l -print`
- if echo "$(distdir)" | grep -q '^/' ; then \
- mkdir -p "$(distdir)/win" ; \
- scripts/mysql_install_db --no-defaults --windows \
- --basedir=$(top_srcdir) \
- --datadir="$(distdir)/win/data"; \
- else \
- mkdir -p "$$(pwd)/$(distdir)/win" ; \
- scripts/mysql_install_db --no-defaults --windows \
- --basedir=$(top_srcdir) \
- --datadir="$$(pwd)/$(distdir)/win/data"; \
- fi
+ mkdir -p $(distdir)/win
+ scripts/mysql_install_db --no-defaults --windows \
+ --basedir=$(top_builddir) \
+ --datadir=$(distdir)/win/data \
+ --srcdir=$(top_srcdir)
tags:
support-files/build-tags