summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-03-27 17:51:30 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-03-27 17:51:30 +0200
commitffa3c301e2fa36b1e7e128e2971e2cc93807e260 (patch)
treeccae91c557e4376f7aef54efd17f9389d636fbb4 /Makefile.am
parent27f8c357602f6e1ac9a80da9c2645245f43f2f25 (diff)
parent0d5a969acea2297d459f8f23c0030796a68cf00e (diff)
downloadmariadb-git-ffa3c301e2fa36b1e7e128e2971e2cc93807e260.tar.gz
Merge mysql.com:/home/kent/bk/tmp/mysql-4.1-build
into mysql.com:/home/kent/bk/tmp/mysql-5.0-build Makefile.am: Added target for RPM debug mysql-test-run
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a1bfc0e32a..ed54b630aea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -147,6 +147,16 @@ test-force-full:
test-force-mem:
$(MAKE) force=--force mem=--mem test
+test-bt:
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=normal --report-features
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=ps --ps-protocol
+
+test-bt-debug:
+ -cd mysql-test ; MTR_BUILD_THREAD=auto \
+ @PERL@ ./mysql-test-run.pl --force --comment=debug --report-features
+
# Keep these for a while
test-pl: test
test-full-pl: test-full