summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <cmiller@calliope.local>2006-07-12 10:26:19 -0400
committerunknown <cmiller@calliope.local>2006-07-12 10:26:19 -0400
commit0daad2ffab20ca89e5d329e3f7f0488814f36d7a (patch)
treee4ed7b1cb800c3feb25f6581d4df40c5a3ddbc41 /configure.in
parent608d060c0499a83443991054e664718a48fe7f23 (diff)
downloadmariadb-git-0daad2ffab20ca89e5d329e3f7f0488814f36d7a.tar.gz
Bug#18470: Compile Failure: strings.s fails make with unknown pseudo-ops
The bug is thqt we use some nonstandard assembly codes in our strings source, and some assemblers don't know what to do with them: Specifically, Sun's Solaris assembler and Apple's Darwin assembler balk at them. This patch, rather than trying to test for properties of the assembler, which Autoconf doesn't have any decent facilites for, instead tries to compile the code in question and disables assembly if it fails. There's still the problem of unportable assembly, but I'll leave that to someone who feels like rewriting and debugging it. configure.in: Actually try to compile the code in question, since a test for the CPU type is insufficient to determine whether our code will compile.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b230b7f042e..b32426595ad 100644
--- a/configure.in
+++ b/configure.in
@@ -718,7 +718,7 @@ AC_ARG_ENABLE(assembler,
AC_MSG_CHECKING(if we should use assembler functions)
# For now we only support assembler on i386 and sparc systems
-AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386")
+AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386" && $AS strings/strings-x86.s -o checkassembler >/dev/null 2>&1 && test -f checkassembler && (rm -f checkassembler; exit 0;))
AM_CONDITIONAL(ASSEMBLER_sparc32, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparc")
AM_CONDITIONAL(ASSEMBLER_sparc64, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparcv9")
AM_CONDITIONAL(ASSEMBLER, test "$ASSEMBLER_x86_TRUE" = "" -o "$ASSEMBLER_sparc32_TRUE" = "")