summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@black.box>2001-09-16 21:41:22 -0400
committerunknown <tim@black.box>2001-09-16 21:41:22 -0400
commit5fffbb123615ad0b256652390467b33ed2919afc (patch)
tree7ff6a4243043fa71bd04fa3434bd8e13992df771 /configure.in
parent34925f8d823c700c939f0622b6af85001458a226 (diff)
downloadmariadb-git-5fffbb123615ad0b256652390467b33ed2919afc.tar.gz
Add some examples for using libmysqld, including a hack for running the
mysql test suite. A few minor libmysqld fixes. Add mysql_server_init() and _end() to mysql.cc and mysqltest.c, so they can be linked against libmysqlclient or libmysqld. sql/mysqld.cc: have unireg_end() exit(), instead of pthread_exit() if inside the EMBEDDED_LIBRARY. This is a hack which hopefully won't be needed. But without it, the program hangs at end. client/mysql.cc: Don't call mysql_ssl_clear() unless HAVE_OPENSSL. client/mysqltest.c: Add mysql_server_init() and _end(). acinclude.m4: change .. to $(top_builddir) in innodb_libs Makefile.am: Add libmysqld/examples to link_sources target configure.in: output libmysqld/examples/Makefile Also, change .. to $(top_builddir) in readline_link BitKeeper/etc/ignore: added linked_libmysqldex_sources mysql-test/mysql-test-run.sh: use latin1, not latin1_de, in tests libmysqld/libmysqld.c: Add replication functions.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1c7e212939d..2ce4621d0ea 100644
--- a/configure.in
+++ b/configure.in
@@ -1804,7 +1804,7 @@ AC_ARG_WITH(readline,
if test "$with_readline" = "yes"
then
readline_dir="readline"
- readline_link="../readline/libreadline.a"
+ readline_link="\$(top_builddir)/readline/libreadline.a"
else
# This requires readline to be in a standard place. Mosty for linux
# there readline may be a shared library.
@@ -2219,7 +2219,8 @@ AC_OUTPUT(Makefile extra/Makefile mysys/Makefile isam/Makefile \
bdb/Makefile \
myisam/Makefile myisammrg/Makefile \
man/Makefile readline/Makefile vio/Makefile \
- libmysql_r/Makefile libmysqld/Makefile libmysql/Makefile client/Makefile \
+ libmysql_r/Makefile libmysqld/Makefile libmysqld/examples/Makefile \
+ libmysql/Makefile client/Makefile \
pstack/Makefile sql/Makefile sql/share/Makefile \
merge/Makefile dbug/Makefile scripts/Makefile \
include/Makefile sql-bench/Makefile tools/Makefile \