summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2001-09-18 15:24:14 +0300
committerunknown <monty@hundin.mysql.fi>2001-09-18 15:24:14 +0300
commite154b30a57cc119f8e47936f23a261324228662f (patch)
tree4b25f7508790da8982dae62b3719ae7f815f230f /configure.in
parentbe94b8d3c84ab16b0db6e4e2e7e1248c2035ecbb (diff)
downloadmariadb-git-e154b30a57cc119f8e47936f23a261324228662f.tar.gz
Another attempt to get pstack into the binary distribution
Fixed that --enable-assembler works on newer Linux system Makefile.am: Another attempt to get pstack into the binary distribution configure.in: Fixed that --enable-assembler works on newer Linux system Fixes for pstack pstack/Makefile.am: Another attempt to get pstack into the binary distribution
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 27 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 8bc274421ab..f6a24498511 100644
--- a/configure.in
+++ b/configure.in
@@ -65,6 +65,12 @@ AC_DEFINE_UNQUOTED(SYSTEM_TYPE, "$SYSTEM_TYPE")
AC_SUBST(MACHINE_TYPE)
AC_DEFINE_UNQUOTED(MACHINE_TYPE, "$MACHINE_TYPE")
+# Detect intel x86 like processor
+BASE_MACHINE_TYPE=$MACHINE_TYPE
+case $MACHINE_TYPE in
+ i?86) BASE_MACHINE_TYPE=i386 ;;
+esac
+
# Save some variables and the command line options for mysqlbug
SAVE_CFLAGS="$CFLAGS"
SAVE_CXXFLAGS="$CXXFLAGS"
@@ -515,12 +521,22 @@ AC_ARG_ENABLE(assembler,
[ ENABLE_ASSEMBLER=$enableval ],
[ ENABLE_ASSEMBLER=no ]
)
+
+AC_MSG_CHECKING(if we should use assembler functions)
# For now we only support assembler on i386 and sparc systems
-AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$MACHINE_TYPE" = "i386")
-AM_CONDITIONAL(ASSEMBLER_sparc, test "$ENABLE_ASSEMBLER" = "yes" -a "$MACHINE_TYPE" = "sparc")
-AM_CONDITIONAL(ASSEMBLER, test ASSEMBLER_x86 = "" -o ASSEMBLER_x86 = "")
+AM_CONDITIONAL(ASSEMBLER_x86, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "i386")
+AM_CONDITIONAL(ASSEMBLER_sparc, test "$ENABLE_ASSEMBLER" = "yes" -a "$BASE_MACHINE_TYPE" = "sparc")
+AM_CONDITIONAL(ASSEMBLER, test "$ASSEMBLER_x86_TRUE" = "" -o "$ASSEMBLER_sparc_TRUE" = "")
-AC_MSG_CHECKING(whether to use RAID)
+if test "$ASSEMBLER_TRUE" = ""
+then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+
+AC_MSG_CHECKING(if we should use RAID)
AC_ARG_WITH(raid,
[ --with-raid Enable RAID Support],
[ USE_RAID=$withval ],
@@ -688,7 +704,7 @@ int main()
[USE_PSTACK=yes])
pstack_libs=
pstack_dirs=
- if test "$USE_PSTACK" = yes -a "$IS_LINUX" = "true" -a "$MACHINE_TYPE" = "i686" -a "$with_mit_threads" = "no"
+ if test "$USE_PSTACK" = yes -a "$IS_LINUX" = "true" -a "$BASE_MACHINE_TYPE" = "i386" -a "$with_mit_threads" = "no"
then
have_libiberty= have_libbfd=
my_save_LIBS="$LIBS"
@@ -698,7 +714,6 @@ dnl I have no idea if this is a good test - can not find docs for libiberty
AC_CHECK_LIB([bfd], [bfd_openr], [have_libbfd=yes], , [-liberty])])
LIBS="$my_save_LIBS"
- AC_MSG_CHECKING([for pstack libs])
if test x"$have_libiberty" = xyes -a x"$have_libbfd" = xyes
then
pstack_dirs='$(top_srcdir)'/pstack
@@ -706,16 +721,20 @@ dnl I have no idea if this is a good test - can not find docs for libiberty
AC_SUBST([pstack_dirs])
AC_SUBST([pstack_libs])
AC_DEFINE([USE_PSTACK])
- AC_MSG_RESULT([yes])
dnl This check isn't needed, but might be nice to give some feedback....
dnl AC_CHECK_HEADER(libiberty.h,
dnl have_libiberty_h=yes,
dnl have_libiberty_h=no)
else
- AC_MSG_RESULT([no (missing libbfd)])
+ USE_PSTACK="no"
fi
+ else
+ USE_PSTACK="no"
fi
fi
+AM_CONDITIONAL(COMPILE_PSTACK, test "$USE_PSTACK" = "yes")
+AC_MSG_CHECKING([if we should use pstack])
+AC_MSG_RESULT([$USE_PSTACK])
# Check for gtty if termio.h doesn't exists
if test "$ac_cv_header_termio_h" = "no" -a "$ac_cv_header_termios_h" = "no"