summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-12-21 23:20:56 +0200
committerOtto Kekäläinen <otto@kekalainen.net>2020-12-21 23:20:56 +0200
commit113f18686d004788f13e3a5bb60ea1c77847c963 (patch)
tree04947dc44182f918718fed1a0eaf3b740271b975 /debian/autobake-deb.sh
parentecb1b8721ba645ccb839fc1b7605483b794be4e1 (diff)
downloadmariadb-git-113f18686d004788f13e3a5bb60ea1c77847c963.tar.gz
Fix previous commit: PLUGIN_COLUMNSTORE=YES can only be active on amd64
Refactor previous commit to fix mistake revealed by Buildbot. We can't have a structure where PLUGIN_COLUMNSTORE would ever be 'YES' on an arch that does not support it, as the flag overrides any potential platform detection code and builds on non-amd64 would all fail.
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 22d910920bd..0d43da12d24 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -24,7 +24,7 @@ if [[ -d storage/columnstore/columnstore/debian ]]; then
cat storage/columnstore/columnstore/debian/control >> debian/control
# Don't build ColumnStore as part of the native build, only build it when triggered
# by autobake-deb.sh
- sed 's|-DPLUGIN_COLUMNSTORE=NO|-DPLUGIN_COLUMNSTORE=YES|' -i debian/rules
+ sed 's|#CMAKEFLAGS += -DPLUGIN_COLUMNSTORE=YES|CMAKEFLAGS += -DPLUGIN_COLUMNSTORE=YES|' -i debian/rules
fi
# General CI optimizations to keep build output smaller