summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2019-01-25 20:33:47 +0100
committerSergei Golubchik <serg@mariadb.org>2019-01-25 20:35:40 +0100
commit3b1b665fcbe1b9ae7ee0d627105cfb69c9886179 (patch)
tree94479c6cb014effd97d7c95a20c0338651f363b1 /debian/autobake-deb.sh
parenta4ab66c8f86d79a1b6bf8aadbe0282e2c71c55a8 (diff)
parent3fb6d2587d6498c50c82aac77062d95ad5f2237a (diff)
downloadmariadb-git-3b1b665fcbe1b9ae7ee0d627105cfb69c9886179.tar.gz
Merge branch '10.2' into 10.3
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 6f859aa01ef..93d2b695397 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -124,6 +124,12 @@ EOF
sed -i -e "/-DPLUGIN_AWS_KEY_MANAGEMENT=NO/d" debian/rules
fi
+# Don't build cassandra package if thrift is not installed
+if [[ ! -f /usr/local/include/thrift/Thrift.h && ! -f /usr/include/thrift/Thrift.h ]]
+then
+ sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
+fi
+
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then