summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-08-23 11:21:33 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2021-08-23 11:21:33 +0300
commit49f95c40656a7333586e3ee11ff981ff41aebd40 (patch)
tree09517d8d34672996e627b7827d004d6a68cc1088 /debian/autobake-deb.sh
parent75c641d22b672a0fb18c34f7065c3eeeb657ded3 (diff)
parent2c9f2a4c8c8b32649d78b94f6e62da57e689f2b5 (diff)
downloadmariadb-git-49f95c40656a7333586e3ee11ff981ff41aebd40.tar.gz
Merge 10.5 into 10.6
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh9
1 files changed, 6 insertions, 3 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 5a78c527e3c..e741193cc46 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -24,10 +24,13 @@ then
# build less verbose
# MCOL-4149: ColumnStore builds are so slow and big that they must be skipped on
# both Travis-CI and Gitlab-CI
- sed -e '/Add support for verbose builds/,/^$/d' \
- -e '/ColumnStore is part of the build/,/^$/d' \
- -e 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' \
+ sed -e 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' \
-i debian/rules
+elif [ -d storage/columnstore/columnstore/debian ]
+then
+ cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
+ echo >> debian/control
+ cat storage/columnstore/columnstore/debian/control >> debian/control
fi
# Don't build or try to put files in a package for selected plugins and components on Travis-CI