summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2019-03-04 17:01:00 +0200
committerMarko Mäkelä <marko.makela@mariadb.com>2019-03-04 17:01:00 +0200
commita2fc36989e13c6f322fd22791f67e0d1275461d7 (patch)
tree9cba675c50883e2e45c61a94b631d8875d16ddf9 /debian/autobake-deb.sh
parent82da98556cf58f0fbb43c82e9c6ae1a887b6cf3d (diff)
parent74d648db12e100c628548fb2e5aa67de718bd1fb (diff)
downloadmariadb-git-a2fc36989e13c6f322fd22791f67e0d1275461d7.tar.gz
Merge 10.2 into 10.3
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh21
1 files changed, 12 insertions, 9 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 5ca59e0305d..4dba4de26b7 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -19,8 +19,8 @@ then
sed -i -e '/Add support for verbose builds/,+2d' debian/rules
# Don't include test suite package on Travis-CI to make the build time shorter
- sed '/Package: mariadb-test-data/,+28d' -i debian/control
- sed '/Package: mariadb-test/,+36d' -i debian/control
+ sed '/Package: mariadb-test-data/,/^$/d' -i debian/control
+ sed '/Package: mariadb-test/,/^$/d' -i debian/control
# Don't build the test package at all to save time and disk space
sed 's|DINSTALL_MYSQLTESTDIR=share/mysql/mysql-test|DINSTALL_MYSQLTESTDIR=false|' -i debian/rules
@@ -47,7 +47,7 @@ GCCVERSION=$(gcc -dumpfullversion -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g
if ! apt-cache madison libcrack2-dev | grep 'libcrack2-dev *| *2\.9' >/dev/null 2>&1
then
sed '/libcrack2-dev/d' -i debian/control
- sed '/Package: mariadb-plugin-cracklib/,+9d' -i debian/control
+ sed '/Package: mariadb-plugin-cracklib/,/^$/d' -i debian/control
fi
# If libpcre3-dev (>= 2:8.35-3.2~) is not available (before Debian Jessie or Ubuntu Wily)
@@ -94,9 +94,12 @@ fi
# x86 32 bit.
if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]] || [[ $TRAVIS ]]
then
- sed '/Package: mariadb-plugin-rocksdb/,+14d' -i debian/control
+ sed '/Package: mariadb-plugin-rocksdb/,/^$/d' -i debian/control
fi
+# Always remove aws plugin, see -DNOT_FOR_DISTRIBUTION in CMakeLists.txt
+sed '/Package: mariadb-plugin-aws-key-management-10.2/,/^$/d' -i debian/control
+
# Don't build cassandra package if thrift is not installed
if [[ ! -f /usr/local/include/thrift/Thrift.h && ! -f /usr/include/thrift/Thrift.h ]]
then
@@ -106,12 +109,12 @@ fi
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then
- sed -i -e "/Package: mariadb-plugin-tokudb/,+19d" debian/control
- sed -i -e "/Package: mariadb-plugin-mroonga/,+17d" debian/control
- sed -i -e "/Package: mariadb-plugin-spider/,+18d" debian/control
- sed -i -e "/Package: mariadb-plugin-oqgraph/,+16d" debian/control
+ sed -i -e "/Package: mariadb-plugin-tokudb/,/^$/d" debian/control
+ sed -i -e "/Package: mariadb-plugin-mroonga/,/^$/d" debian/control
+ sed -i -e "/Package: mariadb-plugin-spider/,/^$/d" debian/control
+ sed -i -e "/Package: mariadb-plugin-oqgraph/,/^$/d" debian/control
sed -i -e "/usr\/lib\/mysql\/plugin\/ha_sphinx.so/d" debian/mariadb-server-10.3.install
- sed -i -e "/Package: libmariadbd-dev/,+19d" debian/control
+ sed -i -e "/Package: libmariadbd-dev/,/^$/d" debian/control
fi
# Adjust changelog, add new version