summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-04-14 12:32:27 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2021-04-14 12:32:27 +0300
commitd2e2d32933823623fa3598c8e2b8a5a322e435bb (patch)
tree4a0094ff26be1e985281ef008433ce1493b58ae7 /debian/autobake-deb.sh
parent72e0601d11ac40a27ce071cba8626612bc625e3c (diff)
parent6c3e860cbf36831c118f6ea183acbbeb3c889bed (diff)
downloadmariadb-git-d2e2d32933823623fa3598c8e2b8a5a322e435bb.tar.gz
Merge 10.5 into 10.6
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index a5677c7fd8c..09db5dc23cb 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -82,6 +82,15 @@ then
sed "/Package: mariadb-plugin-rocksdb/,/^$/d" -i debian/control
fi
+# From Debian Stretch/Ubuntu Bionic onwards dh-systemd is just an empty
+# transitional metapackage and the functionality was merged into debhelper.
+# In Ubuntu Hirsute is was completely removed, so it can't be referenced anymore.
+# Keep using it only on Debian Jessie and Ubuntu Xenial.
+if apt-cache madison dh-systemd | grep 'dh-systemd' >/dev/null 2>&1
+then
+ sed 's/debhelper (>= 9.20160709~),/debhelper (>= 9), dh-systemd,/' -i debian/control
+fi
+
# If rocksdb-tools is not available (before Debian Buster and Ubuntu Disco)
# remove the dependency from the RocksDB plugin so it can install properly
# and instead ship the one built from MariaDB sources