summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSergei Petrunia <psergey@askmonty.org>2018-02-09 13:44:38 +0300
committerSergei Petrunia <psergey@askmonty.org>2018-02-09 13:44:38 +0300
commit7beaa5e34e1fc4a3987351f41b0f0ed1329aeb25 (patch)
tree926debafc6af6dcf2145faaecb01bec38dab452a /debian
parent7c1bd8fa04962bcdf9b9e3ea2d51bdb6d0fb88e9 (diff)
parentcca9b3a933a436fd626f11a87381a857f1b6302a (diff)
downloadmariadb-git-7beaa5e34e1fc4a3987351f41b0f0ed1329aeb25.tar.gz
Merge branch 'bb-10.2-mariarocks' into 10.2
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh7
-rw-r--r--debian/control1
-rw-r--r--debian/mariadb-plugin-rocksdb.install1
3 files changed, 7 insertions, 2 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 688698dad8a..157f33eb298 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -74,12 +74,15 @@ fi
# Convert gcc version to numberical value. Format is Mmmpp where M is Major
# version, mm is minor version and p is patch.
-GCCVERSION=$(gcc -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' -e 's/\.\([0-9]\)/0\1/g' -e 's/^[0-9]\{3,4\}$/&00/')
+# -dumpfullversion & -dumpversion to make it uniform across old and new (>=7)
+GCCVERSION=$(gcc -dumpfullversion -dumpversion | sed -e 's/\.\([0-9][0-9]\)/\1/g' \
+ -e 's/\.\([0-9]\)/0\1/g' \
+ -e 's/^[0-9]\{3,4\}$/&00/')
# Don't build rocksdb package if gcc version is less than 4.8 or we are running on
# x86 32 bit.
if [[ $GCCVERSION -lt 40800 ]] || [[ $(arch) =~ i[346]86 ]]
then
- sed '/Package: mariadb-plugin-rocksdb/,+9d' -i debian/control
+ sed '/Package: mariadb-plugin-rocksdb/,+10d' -i debian/control
fi
if [[ $GCCVERSION -lt 40800 ]]
then
diff --git a/debian/control b/debian/control
index 79936870579..15a7d8d7a36 100644
--- a/debian/control
+++ b/debian/control
@@ -455,6 +455,7 @@ Architecture: any
Depends: mariadb-server-10.2 (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
+Recommends: python-mysqldb
Description: RocksDB storage engine for MariaDB
The RocksDB storage engine is a high performance storage engine, aimed
at maximising storage efficiency while maintaining InnoDB-like performance.
diff --git a/debian/mariadb-plugin-rocksdb.install b/debian/mariadb-plugin-rocksdb.install
index ee45a822e0c..fd71995b6a3 100644
--- a/debian/mariadb-plugin-rocksdb.install
+++ b/debian/mariadb-plugin-rocksdb.install
@@ -1,4 +1,5 @@
etc/mysql/conf.d/rocksdb.cnf etc/mysql/mariadb.conf.d
usr/lib/mysql/plugin/ha_rocksdb.so
usr/bin/mysql_ldb
+usr/bin/myrocks_hotbackup
usr/bin/sst_dump