summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRasmus Johansson <rasmus@mariadb.com>2018-08-02 11:27:22 +0000
committerRasmus Johansson <rasmus@mariadb.com>2018-08-02 11:27:22 +0000
commita89a6e4f774d9b01bee0d33c0b2f0d6a1dfae39d (patch)
tree8ea3ccb20d93abd74e6dc7cb546698cc55d73dd6 /debian
parent1b87cd80a268d333acbf4fc4a3d7527cb5da3d4d (diff)
downloadmariadb-git-a89a6e4f774d9b01bee0d33c0b2f0d6a1dfae39d.tar.gz
Added -j option to dpkg-buildpackage to speed up build
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 56575211c61..4d488767a97 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -160,7 +160,7 @@ fi
# Build the package
# Pass -I so that .git and other unnecessary temporary and source control files
# will be ignored by dpkg-source when creating the tar.gz source package.
-fakeroot dpkg-buildpackage -us -uc -I $BUILDPACKAGE_FLAGS
+fakeroot dpkg-buildpackage -us -uc -I $BUILDPACKAGE_FLAGS -j$(nproc)
# If the step above fails due to missing dependencies, you can manually run
# sudo mk-build-deps debian/control -r -i