summaryrefslogtreecommitdiff
path: root/extra/Makefile.am
diff options
context:
space:
mode:
authorunknown <anjuta@arthur.local>2004-12-14 01:54:16 +0200
committerunknown <anjuta@arthur.local>2004-12-14 01:54:16 +0200
commita3b0f750d1df4d7ab2eaadb75c724955584cdee2 (patch)
tree3c7e9bf79f20247dcb163ed6b61b5242fd9cbf63 /extra/Makefile.am
parentee0378e1755309d4fda3f99608d33fc4a6844e7f (diff)
downloadmariadb-git-a3b0f750d1df4d7ab2eaadb75c724955584cdee2.tar.gz
Added pathes to mysqld_error.h and sql_state.h; fixed segfault bug;
BitKeeper/etc/ignore: added extra/created_include_files extra/Makefile.am: Make sure that mysqld_error.h and sql_state.h are not build in the same time. extra/comp_err.c: Fixed segfault bug libmysqld/Makefile.am: Added path to mysqld_error.h and sql_state.h libmysqld/examples/Makefile.am: Added path to mysqld_error.h and sql_state.h scripts/make_win_src_distribution.sh: Windows version fix
Diffstat (limited to 'extra/Makefile.am')
-rw-r--r--extra/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/extra/Makefile.am b/extra/Makefile.am
index 1ca7c9fb692..7bb401f0729 100644
--- a/extra/Makefile.am
+++ b/extra/Makefile.am
@@ -19,14 +19,21 @@ INCLUDES = @MT_INCLUDES@ -I$(top_srcdir)/include \
-I$(top_srcdir)/extra
LDADD = @CLIENT_EXTRA_LDFLAGS@ ../mysys/libmysys.a \
../dbug/libdbug.a ../strings/libmystrings.a
-BUILT_SOURCES=mysqld_error.h sql_state.h
-pkginclude_HEADERS=$(BUILT_SOURCES)
+BUILT_SOURCES= mysqld_error.h sql_state.h
+pkginclude_HEADERS= $(BUILT_SOURCES)
+created_sources = created_include_files
+CLEANFILES = $(created_sources)
+SUPERCLEANFILES = $(BUILT_SOURCES)
-mysqld_error.h: comp_err
- $(top_builddir)/extra/comp_err --charset=$(srcdir)/../sql/share/charsets --out-dir=$(top_builddir)/sql/share/ --header_file=$(top_builddir)/extra/mysqld_error.h --state_file=$(top_builddir)/extra/sql_state.h --in_file=$(srcdir)/../sql/share/errmsg.txt
+all: $(created_sources)
+
+# This will build mysqld_error.h and sql_state.h
+mysqld_error.h: created_include_files
+sql_state.h: created_include_files
-sql_state.h: comp_err
+created_include_files: comp_err
$(top_builddir)/extra/comp_err --charset=$(srcdir)/../sql/share/charsets --out-dir=$(top_builddir)/sql/share/ --header_file=$(top_builddir)/extra/mysqld_error.h --state_file=$(top_builddir)/extra/sql_state.h --in_file=$(srcdir)/../sql/share/errmsg.txt
+ touch created_include_files
bin_PROGRAMS = replace comp_err perror resolveip my_print_defaults \
resolve_stack_dump mysql_waitpid