summaryrefslogtreecommitdiff
path: root/myisam/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.com>2000-09-20 04:54:10 +0300
committerunknown <monty@donna.mysql.com>2000-09-20 04:54:10 +0300
commit5a2419eb89d2f617e94ebef64ffbef72417ec94c (patch)
tree9809b1ec91af01ed8cc76e542fe1a102e239d9b1 /myisam/Makefile.am
parent5a4aa474d879ac9598941665bef6f0938efc91e1 (diff)
downloadmariadb-git-5a2419eb89d2f617e94ebef64ffbef72417ec94c.tar.gz
Small bug fixes + code for DELETE QUICK
Docs/manual.texi: Change log + bug fixes from the mailing list configure.in: added mlockall include/config-win.h: Fix to use SAFE_MUTEX include/ft_global.h: Free memory include/my_pthread.h: Fix for SAFE_MUTEX on windows myisam/Makefile.am: Fix modes myisam/ft_static.c: Fix language problem with fulltext myisam/ft_stopwords.c: Free memory at end myisam/mi_create.c: Fix language problem with fulltext myisam/mi_delete.c: Added optimization to not join blocks when using delete with QUICK myisam/mi_panic.c: Added freeing of memorty myisam/mi_test2.c: Added quick mode myisam/myisamchk.c: Fixed help text myisam/myisamdef.h: Added optimization to not join blocks when using delete with QUICK mysys/mf_format.c: Don't change case for extension mysys/my_wincond.c: Fix for safe mutex mysys/thr_mutex.c: Fix for safe mutex sql-bench/test-insert.sh: Split delete test to get more information about the times sql/ChangeLog: Changelog sql/ha_myisam.cc: Better OPTIMIZE handling sql/log.cc: Cleanup sql/mysql_priv.h: Fix for safe mutex sql/mysqld.cc: Added define for --one-thread option sql/sql_class.h: Fixed lock_time in slow_log sql/sql_delete.cc: Fix for safe mutex sql/sql_parse.cc: Fix processlist message for new process sql/sql_table.cc: Fix windows problem med CREATE INDEX sql/sql_yacc.yy: Fix for safe mutex sql/table.cc: Made code simpler strings/bmove512.c: Small speed fix support-files/mysql.server.sh: Fixed awk usage
Diffstat (limited to 'myisam/Makefile.am')
-rw-r--r--myisam/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/myisam/Makefile.am b/myisam/Makefile.am
index 70976a86b49..edb801f12fd 100644
--- a/myisam/Makefile.am
+++ b/myisam/Makefile.am
@@ -104,6 +104,7 @@ SUFFIXES = .sh
-e 's!@''PERL_DBD_VERSION''@!@PERL_DBD_VERSION@!' \
-e 's!@''PERL_DATA_DUMPER''@!@PERL_DATA_DUMPER@!' \
$< > $@-t
+ @CHMOD@ +x $@-t
@MV@ $@-t $@
# Don't update the files from bitkeeper