summaryrefslogtreecommitdiff
path: root/plugin/handler_socket/libhsclient/Makefile.am
diff options
context:
space:
mode:
authorMichael Widenius <monty@askmonty.org>2011-02-22 11:15:47 +0200
committerMichael Widenius <monty@askmonty.org>2011-02-22 11:15:47 +0200
commit4ad6d6b6c9e551d84fe727d1f48edc8722098bfd (patch)
treee305bc182a35eaf41802e4cc51a61bfd5bde5cd2 /plugin/handler_socket/libhsclient/Makefile.am
parent38e3787af4ac87274c7ef0e632a97aa1217e284a (diff)
parent2c7d6f12ee10903c3002bba42ee15abc2b89fa8e (diff)
downloadmariadb-git-4ad6d6b6c9e551d84fe727d1f48edc8722098bfd.tar.gz
Merge in new handler and handlersocket code into 5.3 main
Diffstat (limited to 'plugin/handler_socket/libhsclient/Makefile.am')
-rw-r--r--plugin/handler_socket/libhsclient/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/plugin/handler_socket/libhsclient/Makefile.am b/plugin/handler_socket/libhsclient/Makefile.am
new file mode 100644
index 00000000000..0a796fa4f43
--- /dev/null
+++ b/plugin/handler_socket/libhsclient/Makefile.am
@@ -0,0 +1,13 @@
+CXXFLAGS += -fimplicit-templates
+instdir = $(includedir)/handlersocket
+# TODO: these headers should be in dena/
+inst_HEADERS = allocator.hpp config.hpp mutex.hpp string_util.hpp \
+ auto_addrinfo.hpp escape.hpp socket.hpp thread.hpp auto_file.hpp \
+ fatal.hpp string_buffer.hpp util.hpp auto_ptrcontainer.hpp \
+ hstcpcli.hpp string_ref.hpp
+lib_LTLIBRARIES = libhsclient.la
+libhsclient_la_SOURCES = config.cpp escape.cpp fatal.cpp hstcpcli.cpp \
+ socket.cpp string_util.cpp
+#libhsclient_la_LDFLAGS = -static
+libhsclient_la_CFLAGS = $(AM_CFLAGS)
+libhsclient_la_CXXFLAGS = $(AM_CFLAGS)