summaryrefslogtreecommitdiff
path: root/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2019-12-20 15:51:25 +0100
committerSergei Golubchik <serg@mariadb.org>2019-12-21 10:42:12 +0100
commit83b0468c4704ac48ee1ac198264318b878ef6afd (patch)
tree32f54b624591bca4b54a358b2857f6b6ffea8913 /sql/CMakeLists.txt
parent67f928d8c243c57f11ddfc8cd4217d5e55fb2c5f (diff)
downloadmariadb-git-83b0468c4704ac48ee1ac198264318b878ef6afd.tar.gz
dependencies for VS
item_cmpfunc.h includes pcre2.h, so with the bundled pcre2 it has to be built before anything that includes pcre2.h . And item_cmpfunc.h is indirectly included everywhere, also in many plugins. Somehow Ninja and Makefiles generators can still deduce the correct build dependencies, but Visual Studio generator cannot. Two changes: * move pcre2.h from item_cmpfunc.h to item_cmpfunc.cc * create an explicit dependency on pcre2 for the server
Diffstat (limited to 'sql/CMakeLists.txt')
-rw-r--r--sql/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/sql/CMakeLists.txt b/sql/CMakeLists.txt
index 98df1988176..e3e2fba8c78 100644
--- a/sql/CMakeLists.txt
+++ b/sql/CMakeLists.txt
@@ -198,6 +198,10 @@ TARGET_LINK_LIBRARIES(sql
${SSL_LIBRARIES}
${LIBSYSTEMD})
+IF(TARGET pcre2)
+ ADD_DEPENDENCIES(sql pcre2)
+ENDIF()
+
FOREACH(se aria partition perfschema sql_sequence wsrep)
# These engines are used directly in sql sources.
IF(TARGET ${se})