summaryrefslogtreecommitdiff
path: root/sql/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@avenger.(none)>2004-08-12 20:57:18 -0700
committerunknown <brian@avenger.(none)>2004-08-12 20:57:18 -0700
commit518f6daf0a9773a71859418bb0738046f051b733 (patch)
treeb1e231e4026c122f6cbe3584c1bee687679422a6 /sql/Makefile.am
parent0aba089ab34c4200b701672465471709ac06fd7a (diff)
downloadmariadb-git-518f6daf0a9773a71859418bb0738046f051b733.tar.gz
This is the addition of the CSV engine "aka tina". Its an example engine that works as a plain text file.
acconfig.h: Adding HAVE CSV rule acinclude.m4: Build option of csv engine configure.in: Update for building CSV sql/Makefile.am: Added files for CSV build sql/handler.cc: Needed options for CSV to be created. sql/handler.h: CSV type engine enum. sql/mysql_priv.h: Addition of the have_csv_db variable. sql/mysqld.cc: Code to show csv option. sql/set_var.cc: Adding have show variables for both csv and example.
Diffstat (limited to 'sql/Makefile.am')
-rw-r--r--sql/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/sql/Makefile.am b/sql/Makefile.am
index 007239f2e8c..e2d857aaa96 100644
--- a/sql/Makefile.am
+++ b/sql/Makefile.am
@@ -59,7 +59,8 @@ noinst_HEADERS = item.h item_func.h item_sum.h item_cmpfunc.h \
log_event.h sql_repl.h slave.h \
stacktrace.h sql_sort.h sql_cache.h set_var.h \
spatial.h gstream.h client_settings.h tzfile.h \
- tztime.h examples/ha_example.h examples/ha_archive.h
+ tztime.h examples/ha_example.h examples/ha_archive.h \
+ examples/ha_tina.h
mysqld_SOURCES = sql_lex.cc sql_handler.cc \
item.cc item_sum.cc item_buff.cc item_func.cc \
item_cmpfunc.cc item_strfunc.cc item_timefunc.cc \
@@ -90,7 +91,8 @@ mysqld_SOURCES = sql_lex.cc sql_handler.cc \
stacktrace.c repl_failsafe.h repl_failsafe.cc \
gstream.cc spatial.cc sql_help.cc protocol_cursor.cc \
tztime.cc my_time.c \
- examples/ha_example.cc examples/ha_archive.cc
+ examples/ha_example.cc examples/ha_archive.cc \
+ examples/ha_tina.cc
gen_lex_hash_SOURCES = gen_lex_hash.cc
gen_lex_hash_LDADD = $(LDADD) $(CXXLDFLAGS)