summaryrefslogtreecommitdiff
path: root/storage/connect/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@mariadb.com>2021-08-04 12:44:46 +0200
committerVladislav Vaintroub <wlad@mariadb.com>2021-08-05 11:32:41 +0200
commit3cc23c9973394b6626745bd8966c9a8c660468be (patch)
treea136260b210ade6c59a60f8a154e31f9093c6e03 /storage/connect/CMakeLists.txt
parent7308e009c9c2161fa4d3f5532104c7da53e5ac27 (diff)
downloadmariadb-git-3cc23c9973394b6626745bd8966c9a8c660468be.tar.gz
MDEV-25602 Eliminate the rest of __WIN__ in Connect
Diffstat (limited to 'storage/connect/CMakeLists.txt')
-rw-r--r--storage/connect/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/storage/connect/CMakeLists.txt b/storage/connect/CMakeLists.txt
index c3418cca351..a6b30e1bbcd 100644
--- a/storage/connect/CMakeLists.txt
+++ b/storage/connect/CMakeLists.txt
@@ -72,7 +72,7 @@ IF(UNIX)
get_property(inc_dirs DIRECTORY PROPERTY INCLUDE_DIRECTORIES)
SET(CONNECT_SOURCES ${CONNECT_SOURCES} inihandl.cpp)
SET(IPHLPAPI_LIBRARY "")
-ELSE(NOT UNIX)
+ELSE()
SET(CONNECT_SOURCES ${CONNECT_SOURCES}
tabwmi.cpp tabwmi.h tabmac.cpp tabmac.h macutil.cpp macutil.h)
# Add exception handling to the CONNECT project)
@@ -82,8 +82,7 @@ ELSE(NOT UNIX)
# Connect does not work with clang-cl
RETURN()
ENDIF()
- add_definitions(-D__WIN__)
-ENDIF(UNIX)
+ENDIF()
#