summaryrefslogtreecommitdiff
path: root/storage/connect/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2013-04-17 07:44:49 -0700
committerVladislav Vaintroub <wlad@montyprogram.com>2013-04-17 07:44:49 -0700
commit4a3e22c430149b887545acfd5f792c03b39e27a9 (patch)
treeaaf52637084015a0f0d3df8c34d6913f9addc37e /storage/connect/CMakeLists.txt
parent2a20ab78893997eb9df6ee7510f96bf093a5a29c (diff)
downloadmariadb-git-4a3e22c430149b887545acfd5f792c03b39e27a9.tar.gz
Fix MSI package creation for connect engine.
Also, do not use /MP option when compiling CONNECT (incompatible with COM #import directive) Also, fix ODBC_LIBRARY to be a list on Windows, not string with spaces inside.
Diffstat (limited to 'storage/connect/CMakeLists.txt')
-rw-r--r--storage/connect/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/storage/connect/CMakeLists.txt b/storage/connect/CMakeLists.txt
index d5f1e5b16ba..7ad51f42176 100644
--- a/storage/connect/CMakeLists.txt
+++ b/storage/connect/CMakeLists.txt
@@ -117,6 +117,10 @@ ENDIF(CONNECT_WITH_LIBXML2)
IF(WIN32)
+ # /MP option of the Microsoft compiler does not work well with COM #import
+ string(REPLACE "/MP" "" CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
+ string(REPLACE "/MP" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+
OPTION(CONNECT_WITH_MSXML "Compile CONNECT storage engine with MSXML support" ON)
IF(CONNECT_WITH_MSXML)
find_library(MSXML_LIBRARY
@@ -234,7 +238,7 @@ IF(CONNECT_WITH_ODBC)
ENDIF()
ELSE(NOT UNIX)
add_definitions(-DODBC_SUPPORT)
- SET(ODBC_LIBRARY "odbc32.lib odbccp32.lib")
+ SET(ODBC_LIBRARY odbc32.lib odbccp32.lib)
SET(CONNECT_SOURCES ${CONNECT_SOURCES}
tabodbc.cpp tabodbc.h odbccat.h odbconn.cpp odbconn.h)
ENDIF(UNIX)
@@ -248,7 +252,7 @@ ENDIF(CONNECT_WITH_ODBC)
MYSQL_ADD_PLUGIN(connect ${CONNECT_SOURCES}
STORAGE_ENGINE
MODULE_OUTPUT_NAME "ha_connect"
- COMPONENT connect-engine
+ COMPONENT connect_engine
LINK_LIBRARIES ${ZLIB_LIBRARY} ${XML_LIBRARY} ${ICONV_LIBRARY}
${ODBC_LIBRARY} ${IPHLPAPI_LIBRARY})