summaryrefslogtreecommitdiff
path: root/storage/innobase/CMakeLists.txt
diff options
context:
space:
mode:
authorVasil Dimov <vasil.dimov@oracle.com>2010-06-23 13:02:49 +0300
committerVasil Dimov <vasil.dimov@oracle.com>2010-06-23 13:02:49 +0300
commit0a7d57999237fae1d6208c58448ec3fd3a3d698b (patch)
tree362e3efd4d9a12b6e26122c9349b8c14c88c1ab1 /storage/innobase/CMakeLists.txt
parente3d842c60d0fe723b77e92dc63e7dced93639e7c (diff)
downloadmariadb-git-0a7d57999237fae1d6208c58448ec3fd3a3d698b.tar.gz
Enable InnoDB's UNIV_DEBUG if MySQL's WITH_DEBUG[_FULL] is defined
This will make PB2 test InnoDB with UNIV_DEBUG on its *_debug platforms Discussed with: Marko (on IRC)
Diffstat (limited to 'storage/innobase/CMakeLists.txt')
-rw-r--r--storage/innobase/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/storage/innobase/CMakeLists.txt b/storage/innobase/CMakeLists.txt
index 6aec52032f3..23b7fb2d479 100644
--- a/storage/innobase/CMakeLists.txt
+++ b/storage/innobase/CMakeLists.txt
@@ -40,6 +40,10 @@ IF(UNIX)
ENDIF()
ENDIF()
+# Enable InnoDB's UNIV_DEBUG if MySQL's WITH_DEBUG[_FULL] is defined
+IF(WITH_DEBUG OR WITH_DEBUG_FULL)
+ ADD_DEFINITIONS("-DUNIV_DEBUG")
+ENDIF()
IF(NOT MSVC)
# either define HAVE_IB_GCC_ATOMIC_BUILTINS or not