summaryrefslogtreecommitdiff
path: root/storage/mroonga/vendor/groonga/CMakeLists.txt
diff options
context:
space:
mode:
authorLukas Javorsky <ljavorsk@redhat.com>2019-11-22 15:03:20 +0100
committerRobert Bindar <robert@mariadb.org>2021-12-02 16:40:29 +0200
commit045f5f7b10d391fc1653583594b4efbb5a495c4d (patch)
tree5f174d5f4cea9d9dbbc27897416e35dbebfbcf53 /storage/mroonga/vendor/groonga/CMakeLists.txt
parentfafe60e7e2da72488ff3741367a962b45a23b8ee (diff)
downloadmariadb-git-045f5f7b10d391fc1653583594b4efbb5a495c4d.tar.gz
MDEV-21108 Add option for setting install paths of groongabb-10.3-robert
Include gronnga and groonga-normalizer-mysql install path
Diffstat (limited to 'storage/mroonga/vendor/groonga/CMakeLists.txt')
-rw-r--r--storage/mroonga/vendor/groonga/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/storage/mroonga/vendor/groonga/CMakeLists.txt b/storage/mroonga/vendor/groonga/CMakeLists.txt
index 2929338d7b1..8afa53be1e0 100644
--- a/storage/mroonga/vendor/groonga/CMakeLists.txt
+++ b/storage/mroonga/vendor/groonga/CMakeLists.txt
@@ -86,7 +86,9 @@ set(LIB_DIR "lib")
set(INCLUDE_DIR "include")
set(GRN_INCLUDE_DIR "include/groonga")
set(DATA_DIR "share")
-set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
+if(NOT DEFINED GRN_DATA_DIR)
+ set(GRN_DATA_DIR "${DATA_DIR}/${GRN_PROJECT_NAME}")
+endif()
set(CONFIG_DIR "etc")
set(GRN_CONFIG_DIR "${CONFIG_DIR}/${GRN_PROJECT_NAME}")
set(GRN_CONFIG_PATH "${CMAKE_INSTALL_PREFIX}/${GRN_CONFIG_DIR}/groonga.conf")