summaryrefslogtreecommitdiff
path: root/storage/perfschema/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2012-10-30 23:05:55 +0100
committerVladislav Vaintroub <wlad@montyprogram.com>2012-10-30 23:05:55 +0100
commitbc5232a65d395f60fdc46703f30d051a70470382 (patch)
treefd26e1d7a1917dd85825fc66f5e7934ec7729dd4 /storage/perfschema/CMakeLists.txt
parent8d2c12a924582f822d684b78410bd82aac748617 (diff)
downloadmariadb-git-bc5232a65d395f60fdc46703f30d051a70470382.tar.gz
MDEV-672 : storage/maria and storage/perfschema do not appear to honor WITH_UNIT_TESTS
Disable compiling unit tests if WITH_UNIT_TEST is FALSE. Also, fix CMake code to allow compilation WITHOUT_ARIA_STORAGE_ENGINE
Diffstat (limited to 'storage/perfschema/CMakeLists.txt')
-rw-r--r--storage/perfschema/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/storage/perfschema/CMakeLists.txt b/storage/perfschema/CMakeLists.txt
index 7702b7365af..528e7806755 100644
--- a/storage/perfschema/CMakeLists.txt
+++ b/storage/perfschema/CMakeLists.txt
@@ -74,6 +74,6 @@ SET(PERFSCHEMA_SOURCES ha_perfschema.h
)
MYSQL_ADD_PLUGIN(perfschema ${PERFSCHEMA_SOURCES} STORAGE_ENGINE DEFAULT STATIC_ONLY)
-IF(WITH_PERFSCHEMA_STORAGE_ENGINE)
+IF(WITH_PERFSCHEMA_STORAGE_ENGINE AND WITH_UNIT_TESTS)
ADD_SUBDIRECTORY(unittest)
ENDIF()