summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh9
-rwxr-xr-xdebian/rules9
2 files changed, 6 insertions, 12 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 1363f96dc5a..c09ebb1d0cd 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -24,10 +24,13 @@ then
# build less verbose
# MCOL-4149: ColumnStore builds are so slow and big that they must be skipped on
# both Travis-CI and Gitlab-CI
- sed -e '/Add support for verbose builds/,/^$/d' \
- -e '/ColumnStore is part of the build/,/^$/d' \
- -e 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' \
+ sed -e 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' \
-i debian/rules
+elif [ -d storage/columnstore/columnstore/debian ]
+then
+ cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
+ echo >> debian/control
+ cat storage/columnstore/columnstore/debian/control >> debian/control
fi
# Don't build or try to put files in a package for selected plugins and components on Travis-CI
diff --git a/debian/rules b/debian/rules
index 13e5c5e57a7..650f807e0ec 100755
--- a/debian/rules
+++ b/debian/rules
@@ -70,15 +70,6 @@ ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
dh_auto_build --builddirectory=builddir-native -- import_executables
endif
- # ColumnStore is part of the build
-ifneq (32,$(DEB_HOST_ARCH_BITS))
- # Take the files and part of control from MCS directory
- cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
- # Don't include twice
- grep -q '^Package: mariadb-plugin-columnstore$$' debian/control || \
- ( echo && cat storage/columnstore/columnstore/debian/control ) >> debian/control
-endif
-
echo "server:Version=$(DEB_VERSION)" >> debian/substvars
# RocksDB and Column Store cannot build on 32-bit platforms