summaryrefslogtreecommitdiff
path: root/storage/mroonga/vendor/groonga/packages/source/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'storage/mroonga/vendor/groonga/packages/source/Makefile.am')
-rw-r--r--storage/mroonga/vendor/groonga/packages/source/Makefile.am25
1 files changed, 0 insertions, 25 deletions
diff --git a/storage/mroonga/vendor/groonga/packages/source/Makefile.am b/storage/mroonga/vendor/groonga/packages/source/Makefile.am
deleted file mode 100644
index 9940b6800df..00000000000
--- a/storage/mroonga/vendor/groonga/packages/source/Makefile.am
+++ /dev/null
@@ -1,25 +0,0 @@
-all:
-
-release: upload
-
-ensure-rsync-path:
- @if test -z "$(RSYNC_PATH)"; then \
- echo "--with-rsync-path configure option must be specified."; \
- false; \
- fi
-
-download: ensure-rsync-path
- rsync -avz --progress $(RSYNC_PATH)/source/groonga/ files
-
-upload: ensure-rsync-path files/$(PACKAGE)-$(VERSION).tar.gz files/$(PACKAGE)-$(VERSION).zip
- rsync -avz --progress --delete files/ $(RSYNC_PATH)/source/groonga
-
-files/$(PACKAGE)-$(VERSION).tar.gz: $(top_builddir)/$(PACKAGE)-$(VERSION).tar.gz
- mkdir -p files
- cp -p $< $@
-
-files/$(PACKAGE)-$(VERSION).zip: files/$(PACKAGE)-$(VERSION).tar.gz
- rm -rf $(PACKAGE)-$(VERSION)
- tar xvzf files/$(PACKAGE)-$(VERSION).tar.gz
- zip -r $@ $(PACKAGE)-$(VERSION)
- rm -rf $(PACKAGE)-$(VERSION)