summaryrefslogtreecommitdiff
path: root/storage/perfschema/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'storage/perfschema/CMakeLists.txt')
-rw-r--r--storage/perfschema/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/storage/perfschema/CMakeLists.txt b/storage/perfschema/CMakeLists.txt
index 7702b7365af..528e7806755 100644
--- a/storage/perfschema/CMakeLists.txt
+++ b/storage/perfschema/CMakeLists.txt
@@ -74,6 +74,6 @@ SET(PERFSCHEMA_SOURCES ha_perfschema.h
)
MYSQL_ADD_PLUGIN(perfschema ${PERFSCHEMA_SOURCES} STORAGE_ENGINE DEFAULT STATIC_ONLY)
-IF(WITH_PERFSCHEMA_STORAGE_ENGINE)
+IF(WITH_PERFSCHEMA_STORAGE_ENGINE AND WITH_UNIT_TESTS)
ADD_SUBDIRECTORY(unittest)
ENDIF()